Dataphor.org

.NET Framework Upgrade

Modified: 2009/07/07 21:32 by Bryn - Uncategorized
The Dataphor codebase currently targets the 2.0 version of the .NET Framework. We would like to target the latest version of the Framework. In addition, because most of the code base was written pre-2.0, generics were not available. We would like to make use of generics to replace base classes like the TypedList.

Part of the reason for maintaining the 2.0 Framework target was to ensure that the product could be safely deployed in a Mono environment. Research is needed to determine whether or not Mono supports the latest Framework version. If it does not, we could still upgrade and use defines to ensure we maintain compatibility with the 2.0 Framework.

ScrewTurn Wiki version 2.0.36. Some of the icons created by FamFamFam.